Friday, July 03, 2009

A plea to the powers-that-be at Google

Would you please pretty please with sugar on top fix group search?

11 comments:

The Great Hive said...

You're doing it wrong: http://groups.google.com/groups/search?q=comp.lang.c&qt_s=Search+Groups

Ron said...

> You're doing it wrong

Nope. Even that search returns only a few hundred results (it varies day-to-day). I'm pretty sure there have been more posts than that to comp.lang.c :-)

Google Groups search really is broken, and has been for quite a while now.

Ross said...

Um, when I do the search The Great Hive provided (by typing "group:comp.lang.c" into the search box at "http://groups.google.com")

I get "Results 1-10 of about 1,530,000 results ..."

Which seems about right.

Ron said...

It seems to be mainly date-restricted queries that are broken. Try that same search through the advanced search page. If you really want to see the problem, select a date range. For example:

http://groups.google.com/groups/search?safe=off&q=group%3Acomp.lang.c&btnG=Search&as_mind=1&as_minm=1&as_miny=1981&as_maxd=1&as_maxm=1&as_maxy=2008&as_drrb=b&sitesearch=

Ross said...

Yeah, okay, that's completely messed up. I'll ask the groups team tomorrow what is going on (now that I work at Google and all).

Ron said...

Woohoo! Thank you! If you need additional info (I can provide a lot more details, but now that you know what to look for I don't think it will be hard to figure out) you can contact me by email. My address is on my home page (first result when you Google my name).

Ross said...

So I've followed up with the groups team. I can say two things. First, it appears that this hasn't worked for a very long time (possibly since the DejaNews days). Second, the groups team is working on a fix that improves search a lot (including fixing this problem), and though I can't tell you when it will appear, it shouldn't be too long before they get it out the door.

By the way, they already knew about your (Ron Garrett's) specific complaint. It was referenced from the bug that I've seen. So have heart that however you voiced your concern in other forums, the groups team was watching and did take your complaint to heart.

Ron said...

> First, it appears that this hasn't worked for a very long time (possibly since the DejaNews days).

No, this was working recently. I do these kinds of archival searches regularly. I don't remember specifically when the last time was that I did one, but it was certainly less than a year ago.

> By the way, they already knew about your (Ron Garrett's) specific complaint.

Glad to hear it. But if they think this is a problem that is older than a few months then they still don't have the whole story. Is there any way you could put me in touch with whoever is supposed to be working on this?

Ron said...

BTW, Ross, thanks for taking the time to look into this.

AngleBracket said...

I used an automated group search for a piece of research a couple of years ago (with special permission from Google to allow my IP address to make repeated searches). While I have no way of testing or knowing if it worked correctly, when I tried to update the work with more recent material earlier this year (with a renewed permission from them), it returned such a weird set of posts that I retried some of my original searches and they returned a different (and incorrect) set of posts from the original search. My conclusion is that it was working and now isn't. Fortunately enough of it was working to do what I needed, once I sorted the wheat from the chaff.

Ron said...

> with special permission from Google to allow my IP address to make repeated searches

How did you obtain this permission???